Back to overview
Downtime
EU Central, US East, and 3 other services are down
May 5, 2026 at 7:10pm UTC
Affected services
EU Central
US East
Video & Audio
Office
iWork
Resolved
May 5, 2026 at 7:13pm UTC
EU Central, US East, Video & Audio, and 2 other resources recovered.
Affected services
Updated
May 5, 2026 at 7:12pm UTC
Video & Audio, Office, and iWork went down and EU Central and US East are degraded.
Affected services
Updated
May 5, 2026 at 7:10pm UTC
US East recovered.
Affected services
Created
May 5, 2026 at 7:10pm UTC
US East is degraded.
Affected services