Back to overview
Resolved

iWork is down

Aug 3, 2026 at 3:07pm UTC
Affected services
iWork

Resolved
Aug 3, 2026 at 3:13pm UTC

iWork recovered.

Created
Aug 3, 2026 at 3:07pm UTC

iWork is degraded.