Back to overview
Degraded

iWork is down

Apr 10, 2026 at 6:16am UTC
Affected services
iWork

Resolved
Apr 10, 2026 at 6:25am UTC

iWork recovered.

Created
Apr 10, 2026 at 6:16am UTC

iWork is degraded.