Back to overview
Degraded

EU Central and iWork are down

Feb 22, 2026 at 9:24am UTC
Affected services
EU Central
iWork

Resolved
Feb 22, 2026 at 9:28am UTC

iWork recovered.

Updated
Feb 22, 2026 at 9:26am UTC

EU Central recovered.

Created
Feb 22, 2026 at 9:24am UTC

EU Central and iWork are degraded.