Back to overview
Degraded

iWork is down

Feb 12, 2026 at 8:55pm UTC
Affected services
iWork

Resolved
Feb 12, 2026 at 9:16pm UTC

iWork recovered.

Updated
Feb 12, 2026 at 9:13pm UTC

iWork is degraded.

Updated
Feb 12, 2026 at 8:58pm UTC

iWork recovered.

Created
Feb 12, 2026 at 8:55pm UTC

iWork is degraded.