Back to overview
Degraded

iWork is down

Feb 10 at 07:15am CET
Affected services
iWork

Resolved
Feb 10 at 07:23am CET

iWork recovered.

Created
Feb 10 at 07:15am CET

iWork is degraded.