CloudConvert - Slow connections to S3 US-West – Incident details

All systems operational

Slow connections to S3 US-West

Resolved
Degraded performance
Started about 1 month agoLasted less than a minute

Affected

Regions

Operational from 3:17 PM to 3:17 PM

US East

Operational from 3:17 PM to 3:17 PM

Updates
  • Investigating
    Investigating

    We are experiencing slow imports and exports from/to AWS S3 US-West. We are currently investigating this incident.

  • Resolved
    Resolved

    Network speed to AWS US-West is normal again. This incident has been resolved.