All systems operational

Resolved
Degraded performance

Started
June 20, 2023 at 8:00 AM
Status
Resolved after 38 minutes

Impact

Degraded performance
Affected
General
Conversions
Video
Office
iWork
Endpoints
Webinterface
API v2
  • Resolved

    This incident has been resolved.

  • Monitoring

    We implemented a fix and are currently monitoring the result.

  • Identified

    We are experiencing increased error rates and high queue times.