All systems operational

Resolved
Slow S3 US West imports/exports

Started
May 25, 2023 at 10:57 AM
Status
Resolved after about 1 hour

Impact

Degraded performance
Affected
Endpoints
API v2
Conversions
General
Office
  • Resolved

    This incident has been resolved.

  • Identified

    We are currently experiencing slow connections to AWS S3 us-west. This network issue results in import/export tasks stuck in the "processing" state or timeout errors.